iPod/iTunes Question

  • I'm having a problem that I hope some of you can help me with.

    I have imported around 500 CDs into iTunes and onto the iPod, and I have a problem with 4 of them. These four show up in the iTunes library on my pc, but they do not show up on the iPod when I go to 'artists'. The only way I can see that these CDs are actually on the iPod is to list 'songs' on the iPod. Since this list is alphabetical, it's a pain to scroll through just to play one particular track. Plus there is no way to play the whole album, unless I make a playlist. I don't want to do that just for these few albums.

    I haven't changed any settings anywhere within iTunes. I import the same way every time. I've imported a bunch of CDs since these few and I don't have this problem with them.

    Any suggestions would be greatly appreciated :thumbup:

  • Perhaps it's your ID3 tags for those songs?

    Make sure both the 'Artist' and 'Album Artist' fields for each song for those effected albums' songs, are filled in with the appropriate artist name. When they are, they should then show up on the iPod, once you've re-synced.

    To be on the safe-side; I would delete them from the iPod first, before you make the changes within iTunes. Then transfer them over again in the usual manner. That way, you'll be sure to have transferred over the updated version of the songs!

    If that doesn't make a difference, I'd need more from you :)

  • Hey Chip,
    I made a very similar post to yours when I bought chad smith's bombastic meatbats. after i synched my i-pod, i didn't think the cd transfered over. i posted here wondering if anyone knew of anything that was different about that cd. No one seemed to know , although i recall david at least offering advice. Finally, i found it listed under 'albums' and 'songs', but still it is not listed in my 'artist' list. this could actually have happened to some other disc, but that was the only one that i ever noticed. i have never figured out why. i guess that after all is said and done, final answer is still , 'i don't know' :huh:
    peace,

  • Hey Bart....yes, Bombastic Meatbats CD is one I'm having a problem with also. Since you've mentioned your problem again, I do remember now your earlier post.

    David...thanks for the suggestions. Getting ready to try them out now. Will keep you posted.

  • I had this problem with a few cds too. What was causing it was the tag info had the "part of a compilation" option ticked. When I removed this, they showed up on the ipod.

  • I had this problem with a few cds too. What was causing it was the tag info had the "part of a compilation" option ticked. When I removed this, they showed up on the ipod.


    Thanks ststewart. I'll check on that also.

    I didn't perform David's suggestion correctly. Haven't had time lately to mess around with it more. Will get it figured out eventually :)

  • Hi Chip,
    no problem with the Bombastic Meatbats album on my iPod. The only odd thing about it is, that the Artist Name always comes up at 'C' like Chad and not at 'S' like Smith...
    The tags look alright to me aswell.
    Sorry I can't be of any help here! :confused:
    Hope you ge this sorted.
    Cheers,
    Christian

  • Better late than never, but I finally got around to correcting this problem.

    As ststewart said, it's the 'part of compilation' option. I changed it to 'no' and those CDs that weren't showing up in the 'artist' list, are now showing.

    To get to where you change it....search for that album name - highlight all tracks - right click - select 'get info' - click 'options' tab - change to 'no' at 'part of compilation'.

    Didn't even have to delete those CDs first, just changed that setting then synched up the iPod and the change was noticed and it was fixed, so no need to re-import the CDs.

    Thanks ststewart and to everyone else for your suggestions.

    Happy Listening :thumbup:

  • I finally bought an iPod a few months back...I did notice that some selections, especially compilations are at the very end of the cover flow, out of alphabetical sequence. A minor niggle really...but I will check the "Part Of Compilation" tag and see what happens.....

    Here is one thing that is still a mystery..how do you get the iPod to continously play...on the lap top it does but on the actual iPod when you get to the end of the disc you have selected it simply stops....and I don't like messing with it when I am driving...wouldn't want to end up in someone's living room! :eek:

    I know...I COULD go to the Apple site and download the instructions..that would help, right?? ;)

    Stay cool everyone!

    Yours In The Funk
    Bill "Capt. Midnite" Redford

    :ghcp:

    www.facebook.com/bill.redford

    "Cause if you fake the FUNK..your nose got to grow!" Bootsy Collins

  • Under the Settings menu, highlight Shuffle. By pressing the select button you can set it to shuffle songs or albums. Never shuffled albums but I assume you would get random albums played as you would songs. I think another way would be to create a playlist of a certain artist and then it would play all albums by that artist until it got through all of them. Those are just off the top of my head at the moment, I'm sure there might be another way.

    I have a couple of books that come in handy every once in a while, they are iPod & iTunes For Dummies and The iPod Book by Scott Kelby. Both have loads of tips and tricks plus easy explanations on how to do them for those of us, like myself, who aren't computer savvy :thumbup:

  • This is how I do it on my old, battered classic (might be slightly different on a newer nano though).
    Go to the main menu, choose settings then choose repeat and click through the options until you come to "repeat current playlist". Now when you play an album or a playlist it will repeat it over and over.

Join in now!

Don’t have an account yet? Register yourself now and be a part of our community!